Back to overview
Downtime
HQ | MZ iTech Holdings , BPay | By MZ, GPay | By MZ, MZ PAY | By MZ, and 2 other services are down
Feb 25 at 05:22pm GMT+8
Affected services
HQ | MZ iTech Holdings
BPay | By MZ
GPay | By MZ
MZ PAY | By MZ
Resolved
Feb 25 at 05:54pm GMT+8
HQ | MZ iTech Holdings , BPay | By MZ, GPay | By MZ, and 1 other resource recovered.
Affected services
Created
Feb 25 at 05:22pm GMT+8
HQ | MZ iTech Holdings , BPay | By MZ, GPay | By MZ, and 1 other resource went down.
Affected services