Back to overview
Downtime

HQ | MZ iTech Holdings , BPay | By MZ, and 2 other services are down

Jul 5, 2022 at 1:05am UTC
Affected services
HQ | MZ iTech Holdings
BPay | By MZ
GPay | By MZ
MZ PAY | By MZ

Resolved
Jul 9, 2022 at 2:41pm UTC

HQ | MZ iTech Holdings , BPay | By MZ, GPay | By MZ, and 1 other resource recovered.

Created
Jul 5, 2022 at 1:05am UTC

HQ | MZ iTech Holdings , BPay | By MZ, GPay | By MZ, and 1 other resource went down.